DirectorySecurity advisories
Sign in

Directory

wave-fips logoFIPS

wave-fips

Last changed
Sign in for updates

Get notified of upcoming product changes, critical vulnerability notifications and patches and more.

Sign in
Versions
Overview
Provenance
Specifications
SBOM
Vulnerabilities
Advisories

Wave watches Deployments within a Kubernetes cluster and ensures that each Deployment's Pods always have up to date configuration.

Download this Image

The image is available on cgr.dev:

docker pull cgr.dev/chainguard/wave:latest

Compatibility Warning

Starting from versions v0.6.0, wave project add supports for go1.22 with Kubernetes v1.29.

If you are using older versions of Kubernetes, please note that the latest version of wave may or may not be compatible with your Kubernetes version.

If you notice any behavioral changes or issues between your version of wave vs the latest Chainguard image, please file an issue on the upstream repository.

Usage

You can deploy the wave with the Helm:

helm repo add wave-k8s https://wave-k8s.github.io/wave/
helm update
helm install wave wave-k8s/wave \
  --namespace wave \
	--create-namespace \
	--set image.repository="cgr.dev/chainguard/wave" \
	--set image.tag="latest" \

Find more on the Helm Chart values!

Please follow upstream documentation for usage and configuration.

Licenses

Chainguard Images contain software packages that are direct or transitive dependencies. The following licenses were found in the "latest" version of this image:

  • Apache-2.0

  • LGPL-2.1-or-later

  • MIT

  • MPL-2.0

For a complete list of licenses, please refer to this Image's SBOM.

Software license agreement

Compliance

This is a FIPS validated image for FedRAMP compliance.

This image is STIG hardened and scanned against the DISA General Purpose Operating System SRG with reports available.

Learn more about STIGsGet started with STIGs

Related images

Category
FIPS
STIG
application

Products

Chainguard Images

© 2024 Chainguard, Inc.